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Chapter 1. General Information

1.1. Introduction

This document describes how to install OMNeT++ on various platforms. One chapter
is dedicated to each operating system.

1.2. Supported Platforms

OMNeT++ has been tested and is supported on the following operating systems:

• Windows 7, 8 and XP

• Mac OS X 10.7,10.8 and 10.9

• Linux distributions covered in this Installation Guide

The Simulation IDE can be used on the following platforms:

• Linux x86 32/64-bit

• Windows 7, 8 and XP

• Mac OS X 10.7,10.8 and 10.9

Simulations can be run practically on any unix-like environment with a decent and
fairly up-to-date C++ compiler, for example gcc 4.x. Certain OMNeT++ features
(Tkenv, parallel simulation, XML support, etc.) depend on the availability of external
libraries (Tcl/Tk, MPI, LibXML or Expat, etc.)

IDE platforms are restricted because the IDE relies on a native shared library, which
we compile for the above platforms and distribute in binary form for convenience.
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Chapter 2. Windows

2.1. Supported Windows Versions

The supported Windows versions are the Intel 32-bit versions of Windows XP, and later
versions such as Windows 7 and 8.

64-bit Windows versions are also supported, but be aware that binaries bundled with
OMNeT++ are 32-bit ones, and simulations will also be compiled in 32-bit mode.

2.2. Installing OMNeT++

Download the OMNeT++ source code from http://omnetpp.org. Make sure you select
the Windows-specific archive, named omnetpp-4.6-src-windows.zip.

The package is nearly self-contained: in addition to OMNeT++ files it includes a C++
compiler, a command-line build environment, and all libraries and programs required
by OMNeT++.

Copy the OMNeT++ archive to the directory where you want to install it. Choose
a directory whose full path does not contain any space; for example, do not put
OMNeT++ under Program Files.

Extract the zip file. To do so, right-click the zip file in Windows Explorer, and select
Extract All from the menu. You can also use external programs like Winzip or 7zip.
Rename the resulting directory to omnetpp-4.6.

When you look into the new omnetpp-4.6 directory, should see directories named
doc, images, include, tools, etc., and files named mingwenv.cmd, configure,
Makefile, and others.

2.3. Configuring and Building OMNeT++

Start mingwenv.cmd in the omnetpp-4.6 directory by double-clicking it in Windows
Explorer. It will bring up a console with the MSYS bash shell, where the path is already
set to include the omnetpp-4.6/bin directory.

If you want to start simulations from outside the shell as well (for example from
Explorer), you need to add OMNeT++'s bin directory to the path; instructions are
provided later.

First, check the contents of the configure.user file to make sure it contains the
settings you need. In most cases you don’t need to change anything.

notepad configure.user

Then enter the following commands:

$ ./configure
$ make

The build process will create both debug and release binaries.

http://omnetpp.org
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2.4. Verifying the Installation

You should now test all samples and check they run correctly. As an example, the dyna
example is started by entering the following commands:

$ cd samples/dyna
$ ./dyna

By default, the samples will run using the graphical Tkenv environment. You should
see GUI windows and dialogs.

2.5. Starting the IDE

OMNeT++ comes with an Eclipse-based Simulation IDE. You should be able to start
the IDE by typing:

$ omnetpp

We recommend that you create a shortcut for starting the IDE. To do so, locate the
omnetpp.exe program in the omnetpp-4.6/ide directory in Windows Explorer, right-
click it, and choose Send To > Desktop (create shortcut) from the menu. On Windows
7, you can right-click the taskbar icon while the IDE is running, and select Pin this
program to taskbar from the context menu.

When you try to build a project in the IDE, you may get the following warning message:

Toolchain "…" is not supported on this platform or installation. Please
go to the Project menu, and activate a different build configuration. (You
may need to switch to the C/C++ perspective first, so that the required
menu items appear in the Project menu.)

If you encounter this message, choose Project > Properties > C/C++ Build > Tool
Chain Editor > Current toolchain > GCC for OMNeT++.

2.6. Environment Variables

If you want to start OMNeT++ simulations outside the shell as well (for example from
Exlorer), you need to add OMNeT++'s bin directory to the path.

First, open the Environment Variables dialog.

• On Windows XP and Vista: Right-click My Computer, and choose Properties >
Advanced > Environment variables.

• On Windows 7: Click the Start button, then start typing environment variables
into the search box. Choose Edit environment variables for your account when it
appears in the list. The dialog comes up.

In the dialog, select path or PATH in the list, click Edit. Append ";<omnetpp-
dir>\bin" to the value (without quotes), where <omnetpp-dir> is the name of the
OMNeT++ root directory (for example C:\omnetpp-4.6). Hit Enter to accept.

You need to close and re-open any command windows for the changes to take effect
in them.

2.7. Reconfiguring the Libraries

If you need to recompile the OMNeT++ components with different flags (e.g. different
optimization), then change the top-level OMNeT++ directory, edit configure.user
accordingly, then type:
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$ ./configure
$ make clean
$ make

If you want to recompile just a single library, then change to the directory of the library
(e.g. cd src/sim) and type:

$ make clean
$ make

By default, libraries are compiled in both debug and release mode. If you want to make
release or debug builds only, use:

$ make MODE=release

or

$ make MODE=debug

By default, shared libraries will be created. If you want to build static libraries, set
SHARED_LIBS=no in configure.user and re-configure your project.

The built libraries and programs are immediately copied to the lib/ and bin/
subdirs.

2.8. Portability Issues
OMNeT++ has been tested with the MinGW gcc compiler. The current distribution
contains gcc version 4.7.

Microsoft Visual C++ is not supported in the Academic Edition.

2.9. Additional Packages
Note that Doxygen and GraphViz are already included in the OMNeT++ package, and
do not need to be downloaded.

2.9.1. MPI

MPI is only needed if you would like to run parallel simulations.

There are several MPI implementations for Windows, and OMNeT++ does not
mandate any specific one. We recommend DeinoMPI, which can be downloaded from
http://mpi.deino.net.

After installing DeinoMPI, adjust the MPI_DIR setting in OMNeT++'s
configure.user, and reconfigure and recompile OMNeT++:

$ ./configure
$ make cleanall
$ make

In general, if you would like to run parallel simulations, we recommend that you use
Linux, OS X, or another unix-like platform.

2.9.2. PCAP

The optional WinPcap library allows simulation models to capture and transmit
network packets bypassing the operating system’s protocol stack. It is not used directly

http://mpi.deino.net
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by OMNeT++, but OMNeT++ detects the necessary compiler and linker options for
models in case they need it.

2.9.3. Akaroa

Akaroa 2.7.9, which is the latest version at the time of writing, does not support
Windows. You may try to port it using the porting guide from the Akaroa distribution.
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Chapter 3. Mac OS X

3.1. Supported Releases

This chapter provides additional information for installing OMNeT++ on Mac OS X.

The following releases are covered:

• Mac OS X 10.7 (Lion)

• Mac OS X 10.8 (Mountain Lion)

• Mac OS X 10.9 (Mavericks)

• Mac OS X 10.10 (Yosemite)

3.2. Installing the Prerequisite Packages

• Install the Java Runtime from http://support.apple.com/kb/DL1572 , because OS X
does not provide it by default. Additionally you must install the latest version of Java
Runtime Environment from http://java.com (version 1.7 or later.)

• Install the command line developer tools for OS X from http://developer.apple.com/
downloads/index.action?=Command%20Line%20Tools (you will need a free Apple
Developer Account for the download.)

• Install the quartz project from http://xquartz.macosforge.org/. Quartz will provide
some X headers required by the simulation runtime environment.

Installing additional packages will enable more functionality in OMNeT++; see the
Additional packages section at the end of this chapter.

3.3. Additional Steps Required on Mac OS X 10.9 or Later

The Command Line Tools package on Mac OS X 10.9 no longer contains gcc and gdb;
instead it contains the Clang compiler and lldb. (The gcc and g++ commands actually
run clang.) OMNeT++ will use Clang automatically. However, the OMNeT++ IDE can
only use gdb as the underlying debugger, but not lldb.

To be able to debug from the IDE, you have to install gdb from MacPorts. Alternatively,
you can use XCode for debugging.

To do the former, first install MacPorts from http://macports.org. Then you can install
gdb:

$ sudo port install gdb

OS X 10.9 and later requires that you sign the ggdb executable with a self-signed
certificate (or with your own certificate, if you have one.)

Start the Keychain Access application. Choose Keychain Access > Certificate
Assistant > Create a Certificate… from the menu.

Choose a name (e.g. gdb-cert), set Identity Type to Self Signed Root, set Certificate
Type to Code Signing and select the Let me override defaults. Click several times on

http://support.apple.com/kb/DL1572
http://java.com
http://developer.apple.com/downloads/index.action?=Command%20Line%20Tools
http://developer.apple.com/downloads/index.action?=Command%20Line%20Tools
http://xquartz.macosforge.org/
http://macports.org
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Continue until you get to the Specify a Location For The Certificate screen, then set
Keychain to System.

If you can’t store the certificate in the System keychain, create it in the Login keychain,
then export it. You can then import it into the System keychain.

Finally, using the context menu for the certificate, select Get Info, open the Trust item,
and set Code Signing to Always Trust.

You must quit the Keychain Access application in order to use the certificate and restart
the system.

Now sign the executable:

$ sudo codesign -s gdb-cert /opt/local/bin/ggdb

After installing the OMNeT++ IDE, you have to change the name of the executable used
for debugging. Go to Preferences > C++ > Debug > gdb in the IDE, and change the
executable name from gdb to ggdb.

3.4. Downloading and Unpacking OMNeT++
Download OMNeT++ from http://omnetpp.org. Make sure you select to download the
generic archive, omnetpp-4.6-src.tgz.

Copy the archive to the directory where you want to install it. This is usually your home
directory, /Users/<you>. Open a terminal, and extract the archive using the following
command:

$ tar zxvf omnetpp-4.6-src.tgz

A subdirectory called omnetpp-4.6 will be created, containing the simulator files.

Alternatively, you can also unpack the archive using Finder.

The Terminal can be found in the Applications / Utilities folder.

3.5. Environment Variables
OMNeT++ needs its bin/ directory to be in the path. To add bin/ to PATH temporarily
(in the current shell only), change into the OMNeT++ directory and source the setenv
script:

$ cd omnetpp-4.6
$ . setenv

To set the environment variables permanently, edit .bashrc in your home directory.
Use your favourite text editor to edit .bashrc, for example TextEdit:

$ touch ~/.bashrc
$ open -e ~/.bashrc

touch is needed because open -e only opens existing files. Alternatively, you can use
the terminal-based pico editor (pico ~/.bashrc)

Add the following line at the end of the file, then save it:

export PATH=$PATH:$HOME/omnetpp-4.6/bin

http://omnetpp.org
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You need to close and re-open the terminal for the changes to take effect.

Alternatively, you can put the above line into ~/.bash_profile, but then you need to
log out and log in again for the changes to take effect.

If you use a shell other than the default one, bash, consult the man page of that shell
to find out which startup file to edit, and how to set and export variables.

3.6. Configuring and Building OMNeT++
Check configure.user to make sure it contains the settings you need. In most cases
you don’t need to change anything in it.

In the top-level OMNeT++ directory, type:

$ ./configure

The configure script detects installed software and configuration of your system.
It writes the results into the Makefile.inc file, which will be read by the makefiles
during the build process.

Normally, the configure script needs to be running under the graphical environment
in order to test for wish, the Tcl/Tk shell. If you are logged in via an ssh session or you
want to compile OMNeT++ without Tcl/Tk, use the command

$ NO_TCL=1 ./configure

instead of plain ./configure.

If there is an error during configure, the output may give hints about what went
wrong. Scroll up to see the messages. (You may need to increase the scrollback buffer
size of the terminal and re-run ./configure.) The script also writes a very detailed
log of its operation into config.log to help track down errors. Since config.log is
very long, it is recommended that you open it in an editor and search for phrases like
error or the name of the package associated with the problem.

When ./configure has finished, you can compile OMNeT++. Type in the terminal:

$ make

To take advantage of multiple processor cores, add the -j4 option to the make
command line.

The build process will not write anything outside its directory, so no special privileges
are needed.

The make command will seemingly compile everything twice. This is because both
debug and optimized versions of the libraries are built. If you only want to build one
set of the libraries, specify MODE=debug or MODE=release:

$ make MODE=release

3.7. Verifying the Installation
You can now verify that the sample simulations run correctly. For example, the dyna
simulation is started by entering the following commands:
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$ cd samples/dyna
$ ./dyna

By default, the samples will run using the Tcl/Tk environment. You should see nice gui
windows and dialogs.

3.8. Starting the IDE

OMNeT++ comes with an Eclipse-based Simulation IDE. On Mac OS X 10.7 (Lion)
or later, the Java Runtime must be installed (see prerequisites) before you can use the
IDE. Start the IDE by typing:

$ omnetpp

If you would like to be able to launch the IDE via Applications, the Dock or a desktop
shortcut, do the following: open the omnetpp-4.6 folder in Finder, go into the ide
subfolder, create an alias for the omnetpp program there (right-click, Make Alias), and
drag the new alias into the Applications folder, onto the Dock, or onto the desktop.

Alternatively, run one or both of the commands below:

$ make install-menu-item
$ make install-desktop-icon

which will do roughly the same.

3.9. Using the IDE

When you try to build a project in the IDE, you may get the following warning message:

Toolchain "…" is not supported on this platform or installation. Please
go to the Project menu, and activate a different build configuration. (You
may need to switch to the C/C++ perspective first, so that the required
menu items appear in the Project menu.)

If you encounter this message, choose Project > Properties > C/C++ Build > Tool
Chain Editor > Current toolchain > GCC for OMNeT++.

The IDE is documented in detail in the User Guide.

3.10. Reconfiguring the Libraries

If you need to recompile the OMNeT++ components with different flags (e.g. different
optimization), then change the top-level OMNeT++ directory, edit configure.user
accordingly, then type:

$ ./configure
$ make clean
$ make

To take advantage of multiple processor cores, add the -j2 option to the make
command line.

If you want to recompile just a single library, then change to the directory of the library
(e.g. cd src/sim) and type:

$ make clean
$ make
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By default, libraries are compiled in both debug and release mode. If you want to make
release or debug builds only, use:

$ make MODE=release

or

$ make MODE=debug

By default, shared libraries will be created. If you want to build static libraries, set
SHARED_LIBS=no in configure.user and re-configure your project.

The built libraries and programs are immediately copied to the lib/ and bin/
subdirectories.

The Tcl/Tk environment uses the native Aqua version of Tcl/Tk, so you will see native
widgets. However, due to problems in the Tk/Aqua port, you may experience minor UI
quirks. We are aware of these problems, and are working on the solution.

3.11. Additional Packages

3.11.1. OpenMPI

OS X does not come with OpenMPI, so you must install it manually. Download it
from http://open-mpi.org and follow the installation instructions. Alternatively, you
can install it from the MacPorts repo by typing sudo port install openmpi.
In this case, you have to manually set the MPI_CFLAGS and MPI_LIBS variables
in configure.user and re-run ./configure. Please note that we do not provide
support for OpenMPI installed from the MacPorts repository.

MacPorts is a repository of several open source packages for Mac OS X. Using MacPorts
packages may save you some manual work. You can install MacPorts from http://
www.macports.org.

3.11.2. GraphViz

GraphViz is needed if you want to have diagrams in HTML documentation that you
generate from NED files in the IDE (Generate NED Documentation… item in the
project context menu).

Download and install the GraphViz OS X binaries from http://www.pixelglow.com/
graphviz/download/. Download the latest, version 2.x package; at the time of writing,
the link is at the top of the page.

Alternatively, you can install it from the MacPorts project by typing sudo port
install graphviz.

After installation, make sure that the dot program is available from the command line.
Open a terminal, and type

$ dot -V

Note the capital V. The command should normally work out of the box. If you get the
"command not found" error, you need to put dot into the path. Find the dot program
in the GraphViz installation directory, and soft link it into /usr/local/bin (sudo ln
-s <path>/dot /usr/local/bin).

http://open-mpi.org
http://www.macports.org
http://www.macports.org
http://www.pixelglow.com/graphviz/download/
http://www.pixelglow.com/graphviz/download/
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3.11.3. Doxygen

Doxygen is needed if you want to generate documentation for C++ code, as part of
the HTML documentation that you generate from NED files in the IDE (Generate NED
Documentation… item in the project context menu).

Download the Doxygen OS X binaries from the Doxygen web site’s download page,
http://www.stack.nl/~dimitri/doxygen/download.html, and install it.

Alternatively, you can install it from the MacPorts project by typing sudo port
install doxygen.

After installation, ensure that the doxygen program is available from the command
line. Open a terminal, and type

$ doxygen

If you get the "command not found" error, you need to put doxygen into the path. Enter
into a terminal:

$ cd /Applications/Doxygen.app/Contents/Resources/
$ sudo ln -s doxygen doxytags /usr/local/bin

3.11.4. Akaroa

Akaroa 2.7.9, which is the latest version at the time of writing, does not support Mac
OS X. You may try to port it using the porting guide from the Akaroa distribution.

http://www.stack.nl/~dimitri/doxygen/download.html
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Chapter 4. Linux

4.1. Supported Linux Distributions

This chapter provides instructions for installing OMNeT++ on selected Linux
distributions:

• Ubuntu 12.04 LTS, 13.04

• Fedora Core 18

• Red Hat Enterprise Linux Desktop Workstation 6.4

• OpenSUSE 12.3

This chapter describes the overall process. Distro-specific information, such as how
to install the prerequisite packages, are covered by distro-specific chapters.

If your Linux distribution is not listed above, you still may be able to use some distro-
specific instructions in this Guide.

Ubuntu derivatives (Ubuntu instructions may apply):

• Kubuntu, Xubuntu, Edubuntu, …

• Linux Mint

Some Debian-based distros (Ubuntu instructions may apply, as Ubuntu itself is based
on Debian):

• Knoppix and derivatives

• Mepis

Some Fedora-based distros (Fedora instructions may apply):

• Simplis

• Eeedora

4.2. Installing the Prerequisite Packages

OMNeT++ requires several packages to be installed on the computer. These packages
include the C++ compiler (gcc), the Java runtime, and several other libraries and
programs. These packages can be installed from the software repositories of your Linux
distribution.

See the chapter specific to your Linux distribution for instructions on installing
the packages needed by OMNeT++.

Generally, you will need superuser permissions to install packages.

Not all packages are available from software repositories; some (optional) ones need to
be downloaded separately from their web sites, and installed manually. See the section
Additional Packages later in this chapter.
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4.3. Downloading and Unpacking

Download OMNeT++ from http://omnetpp.org. Make sure you select to download the
generic archive, omnetpp-4.6-src.tgz.

Copy the archive to the directory where you want to install it. This is usually your home
directory, /home/<you>. Open a terminal, and extract the archive using the following
command:

$ tar xvfz omnetpp-4.6-src.tgz

This will create an omnetpp-4.6 subdirectory with the OMNeT++ files in it.

On how to open a terminal on your Linux installation, see the chapter specific to your
Linux distribution.

4.4. Environment Variables

OMNeT++ needs its bin/ directory to be in the path. To add bin/ to PATH temporarily
(in the current shell only), change into the OMNeT++ directory and source the setenv
script:

$ cd omnetpp-4.6
$ . setenv

The script also adds the lib/ subdirectory to LD_LIBRARY_PATH, which may be
necessary on systems that don’t support the rpath mechanism.

To set the environment variables permanently, edit .bashrc in your home directory.
Use your favourite text editor to edit .bashrc, for example gedit:

$ gedit ~/.bashrc

Add the following line at the end of the file, then save it:

export PATH=$PATH:$HOME/omnetpp-4.6/bin

You need to close and re-open the terminal for the changes to take effect.

Alternatively, you can put the above line into ~/.bash_profile, but then you need to
log out and log in again for the changes to take effect.

If you use a shell other than bash, consult the man page of that shell to find out which
startup file to edit, and how to set and export variables.

Note that all Linux distributions covered in this Installation Guide use bash unless
the user has explicitly selected another shell.

4.5. Configuring and Building OMNeT++

In the top-level OMNeT++ directory, type:

$ ./configure

The configure script detects installed software and configuration of your system.
It writes the results into the Makefile.inc file, which will be read by the makefiles
during the build process.

http://omnetpp.org
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Figure 4.1. Configuring OMNeT++

Normally, the configure script needs to be running under the graphical environment
(X11) in order to test for wish, the Tcl/Tk shell. If you are logged in via an ssh session,
or there is some other reason why X is not running, the easiest way to work around
the problem is to tell OMNeT++ to build without Tcl/Tk. To do that, use the command

$ NO_TCL=1 ./configure

instead of plain ./configure.

If there is an error during configure, the output may give hints about what went
wrong. Scroll up to see the messages. (Use Shift+PgUp; you may need to increase the
scrollback buffer size of the terminal and re-run ./configure.) The script also writes
a very detailed log of its operation into config.log to help track down errors. Since
config.log is very long, it is recommended that you open it in an editor and search
for phrases like error or the name of the package associated with the problem.

When ./configure has finished, you can compile OMNeT++. Type in the terminal:

$ make
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Figure 4.2. Building OMNeT++

To take advantage of multiple processor cores, add the -j2 option to the make
command line.

The build process will not write anything outside its directory, so no special privileges
are needed.

The make command will seemingly compile everything twice. This is because both
debug and optimized versions of the libraries are built. If you only want to build one
set of the libraries, specify MODE=debug or MODE=release:

$ make MODE=release

4.6. Verifying the Installation

You can now verify that the sample simulations run correctly. For example, the dyna
simulation is started by entering the following commands:

$ cd samples/dyna
$ ./dyna

By default, the samples will run using the Tcl/Tk environment. You should see nice gui
windows and dialogs.

4.7. Starting the IDE

You can launch the OMNeT++ Simulation IDE by typing the following command in
the terminal:

$ omnetpp
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Figure 4.3. The Simulation IDE

If you would like to be able to access the IDE from the application launcher or via a
desktop shortcut, run one or both of the commands below:

$ make install-menu-item
$ make install-desktop-icon

Or add a shortcut that points to the omnetpp program in the ide subdirectory by other
means, for example using the Linux desktop’s context menu.

4.8. Using the IDE

When you try to build a project in the IDE, you may get the following warning message:

Toolchain "…" is not supported on this platform or installation. Please
go to the Project menu, and activate a different build configuration. (You
may need to switch to the C/C++ perspective first, so that the required
menu items appear in the Project menu.)

If you encounter this message, choose Project > Properties > C/C++ Build > Tool
Chain Editor > Current toolchain > GCC for OMNeT++.

The IDE is documented in detail in the User Guide.

4.9. Reconfiguring the Libraries

If you need to recompile the OMNeT++ components with different flags (e.g. different
optimization), then change the top-level OMNeT++ directory, edit configure.user
accordingly, then type:

$ ./configure
$ make cleanall
$ make

If you want to recompile just a single library, then change to the directory of the library
(e.g. cd src/sim) and type:

$ make clean
$ make

By default, libraries are compiled in both debug and release mode. If you want to make
release or debug builds only, use:
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$ make MODE=release

or

$ make MODE=debug

By default, shared libraries will be created. If you want to build static libraries, set
SHARED_LIBS=no in configure.user and re-configure your project.

For detailed description of all options please read the Build Options chapter.

4.10. Additional Packages

Note that at this point, MPI, Doxygen and GraphViz have been installed as part of the
prerequisites.

4.10.1. Akaroa

Linux distributions do not contain the Akaroa package. It must be downloaded,
compiled and installed manually before installing OMNeT++.

As of version 2.7.9, Akaroa only supports Linux and Solaris.

Download Akaroa 2.7.9 from: http://www.cosc.canterbury.ac.nz/research/RG/net_sim/
simulation_group/akaroa/download.chtml

Extract it into a temporary directory:

$ tar xfz akaroa-2.7.9.tar.gz

Configure, build and install the Akaroa library. By default, it will be installed into the
/usr/local/akaroa directory.

$ ./configure
$ make
$ sudo make install

Go to the OMNeT++ directory, and (re-)run the configure script. Akaroa will be
automatically detected if you installed it to the default location.

4.10.2. PCAP

The optional Pcap library allows simulation models to capture and transmit network
packets bypassing the operating system’s protocol stack. It is not used directly by
OMNeT++, but OMNeT++ detects the necessary compiler and linker options for
models in case they need it.

4.10.3. Nemiver

Nemiver is the default debugger for the OMNeT++ just-in-time debugging facility (see
the debugger-attach-on-startup and debugger-attach-on-error configuration
options). Nemiver can be installed via the package manager in most Linux distros. For
example, on Ubuntu and other Debian-based distros you can install it by the following
command:

$ sudo apt-get install nemiver

http://www.cosc.canterbury.ac.nz/research/RG/net_sim/simulation_group/akaroa/download.chtml
http://www.cosc.canterbury.ac.nz/research/RG/net_sim/simulation_group/akaroa/download.chtml
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Chapter 5. Ubuntu

5.1. Supported Releases

This chapter provides additional information for installing OMNeT++ on Ubuntu
Linux installations. The overall installation procedure is described in the Linux
chapter.

The following Ubuntu releases are covered:

• Ubuntu 12.04 LTS

• Ubuntu 13.10

They were tested on the following architectures:

• Intel 32-bit and 64-bit

The instructions below assume that you use the Gnome desktop and the bash shell,
which are the defaults. If you use another desktop environment or shell, you may need
to adjust the instructions accordingly.

5.2. Opening a Terminal

Type terminal in Dash and click on the Terminal icon.

5.3. Installing the Prerequisite Packages

You can perform the installation using the graphical user interface or from the terminal,
whichever you prefer.

5.3.1. Command-Line Installation

Before starting the installation, refresh the database of available packages. Type in the
terminal:

$ sudo apt-get update

To install the required packages, type in the terminal:

$ sudo apt-get install build-essential gcc g++ bison flex perl \
      tcl-dev tk-dev libxml2-dev zlib1g-dev default-jre \
      doxygen graphviz libwebkitgtk-1.0-0 openmpi-bin \
      libopenmpi-dev libpcap-dev

At the confirmation questions (Do you want to continue? [Y/N]), answer Y.
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Figure 5.1. Command-Line Package Installation

5.3.2. Graphical Installation

Ubuntu’s graphical installer, Synaptic, can be started with the System >
Administration > Synaptic package manager menu item.

Since software installation requires root permissions, Synaptic will ask you to type
your password.

Search for the following packages in the list, click the squares before the names, then
choose Mark for installation or Mark for upgrade.

If the Mark additional required changes? dialog comes up, choose the Mark button.

The packages:

• build-essential, gcc, g++, bison, flex, perl, tcl-dev, tk-dev, libxml2-dev, zlib1g-dev,
default-jre, doxygen, graphviz, libwebkitgtk-1.0-0, openmpi-bin, libopenmpi-dev,
libpcap-dev
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Figure 5.2. Synaptic Package Manager

Click Apply, then in the Apply the following changes? window, click Apply again. In
the Changes applied window, click Close.

5.3.3. Post-Installation Steps

Fixing Tooltip Colors

The default tooltip background color in Ubuntu is black, which causes certain tooltips
in the OMNeT++ IDE to become unreadable (black-on-black). This annoyance can be
resolved by changing the tooltip colors in Ubuntu.

Figure 5.3. Black-on-black text in tooltips

Install gnome-color-chooser:

$ sudo apt-get install gnome-color-chooser

Run it:

$ gnome-color-chooser
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Find the Tooltips group on the Specific tab, and change the settings to black foreground
over pale yellow background. Click Apply.

Figure 5.4. Fixing the tooltip color issue

Setting Up Debugging

By default, Ubuntu does not allow ptracing of non-child processes by non-root
users. That is, if you want to be able to debug simulation processes by attaching
to them with a debugger, or similar, you want to be able to use OMNeT++ just-in-
time debugging (debugger-attach-on-startup and debugger-attach-on-error
configuration options), you need to explicitly enable them.

To temporarily allow ptracing non-child processes, enter the following command:

$ echo 0 | sudo tee /proc/sys/kernel/yama/ptrace_scope

To permanently allow it, edit /etc/sysctl.d/10-ptrace.conf and change the line:

kernel.yama.ptrace_scope = 1

to read

kernel.yama.ptrace_scope = 0

Note that the default debugger for OMNeT++ just-in-time debugging is Nemiver, so it
also needs to be installed:

$ sudo apt-get install nemiver
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Chapter 6. Fedora 18

6.1. Supported Releases

This chapter provides additional information for installing OMNeT++ on Fedora
installations. The overall installation procedure is described in the Linux chapter.

The following Fedora release is covered:

• Fedora 18

It was tested on the following architectures:

• Intel 32-bit and 64-bit

6.2. Opening a Terminal

Choose Applications > System Tools > Terminal from the menu.

6.3. Installing the Prerequisite Packages

You can perform the installation using the graphical user interface or from the terminal,
whichever you prefer.

6.3.1. Command-Line Installation

To install the required packages, type in the terminal:

$ su -c 'yum install make gcc gcc-c++ bison flex perl \
    tcl-devel tk-devel libxml2-devel zlib-devel \
    java doxygen graphviz webkitgtk openmpi-devel libpcap-devel'

then follow the instruction on the console.

Note that openmpi will not be available by default, it needs to be activated in every
session with the

$ module load openmpi-<arch>

command, where <arch> is your architecture (usually i386 or x86_64). When in
doubt, use module avail to display the list of available modules. If you need MPI
in every session, you may add the module load command to your startup script
(.bashrc).

6.3.2. Graphical Installation

The graphical installer can be launched by choosing System > Administration > Add/
Remove Software from the menu.
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Figure 6.1. Add/Remove Software

Search for the following packages in the list. Select the checkboxes in front of the
names, and pick the latest version of each package.

The packages:

• bison, gcc, gcc-c++, flex, perl, tcl-devel, tk-devel, libxml2-devel, zlib-devel,
webkitgtk, make, java, doxygen, graphviz, openmpi-devel, libpcap-devel

Click Apply, then follow the instructions.
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Chapter 7. Red Hat

7.1. Supported Releases

This chapter provides additional information for installing OMNeT++ on Red Hat
Enterprise Linux installations. The overall installation procedure is described in the
Linux chapter.

The following Red Hat release is covered:

• Red Hat Enterprise Linux Desktop Workstation 6.4

It was tested on the following architectures:

• Intel 32-bit and 64-bit

7.2. Opening a Terminal

Choose Applications > Accessories > Terminal from the menu.

7.3. Installing the Prerequisite Packages

You can perform the installation using the graphical user interface or from the terminal,
whichever you prefer.

You will need Red Hat Enterprise Linux Desktop Workstation for OMNeT++. The
Desktop Client version does not contain development tools.

7.3.1. Command-Line Installation

To install the required packages, type in the terminal:

$ su -c 'yum install make devtoolset-1.1 bison flex perl \
    tcl-devel tk-devel libxml2-devel zlib-devel \
    java doxygen graphviz openmpi-devel libpcap'

After installing the devtoolset-1.1 package you must make it available to OMNeT++:

$ scl enable devtoolset-1.1 'bash'

This command will open a new shell configured to use the newest available version of
the GCC toolchain. Follow the general Linux installation instructions using this shell.

Activate the devtoolset package in the terminal each time when you work with
OMNeT++ and start the IDE from that shell.

RedHat contains two separate GCC toolchains. The devtoolset package contains the
latest available version of GCC while the system default gcc and gcc-c++ packages are
using a much older version. You may opt to use the system default GCC toolchain by
installing the gcc and gcc-c++ packages instead of devtools-1.1. In this case you don’t
have to use the above scl command.
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To install additional (optional) packages for parallel simulation and packet capture
support, type:

$ su -c 'yum install openmpi-devel libpcap'

Note that openmpi will not be available by default, it needs to be activated in every
session with the

$ module load openmpi_<arch>

command, where <arch> is your architecture (usually i386 or x86_64). When in
doubt, use module avail to display the list of available modules. If you need MPI
in every session, you may add the module load command to your startup script
(.bashrc).`

7.3.2. Graphical Installation

The graphical installer can be launched by choosing Applications > Add/Remove
Software from the menu.

Search for the following packages in the list. Select the checkboxes in front of the
names, and pick the latest version of each package.

The packages:

• devtoolset-1.1, bison, flex, perl, tcl-devel, tk-devel, libxml2-devel, zlib-devel, make,
java, doxygen, graphviz, openmpi-devel, libpcap

Click Apply, then follow the instructions.

7.4. SELinux

You may need to turn off SELinux when running certain simulations. To do so, click
on System > Administration > Security Level > Firewall, go to the SELinux tab, and
choose Disabled.

You can verify the SELinux status by typing the sestatus command in a terminal.

From OMNeT++ 4.1 on, makefiles that build shared libraries include the chcon -t
textrel_shlib_t lib<name>.so command that properly sets the security context
for the library. This should prevent the SELinux-related "cannot restore segment prot
after reloc: Permission denied" error from occurring, unless you have a shared library
which was built using an obsolete or hand-crafted makefile that does not contain the
chcon command.
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Chapter 8. OpenSUSE

8.1. Supported Releases

This chapter provides additional information for installing OMNeT++ on openSUSE
installations. The overall installation procedure is described in the Linux chapter.

The following openSUSE release is covered:

• openSUSE 12.3

It was tested on the following architectures:

• Intel 32-bit and 64-bit

8.2. Opening a Terminal

Choose Applications > System > Terminal > Terminal from the menu.

8.3. Installing the Prerequisite Packages

You can perform the installation using the graphical user interface or from the terminal,
whichever you prefer.

8.3.1. Command-Line Installation

To install the required packages, type in the terminal:

$ sudo zypper install make gcc gcc-c++ bison flex perl \
    tcl-devel tk-devel libxml2-devel zlib-devel \
    java-1_7_0-openjdk doxygen graphviz openmpi-devel libpcap-devel \
    libwebkitgtk-1_0-0

then follow the instruction on the console.

Note that openmpi will not be available by default, first you need to log out and log in
again, or source your .profile script:

$ . ~/.profile

8.3.2. Graphical Installation

The graphical installer can be launched by choosing Computer > Yast > System >
Software > Software Management from the menu.



OpenSUSE

27

Figure 8.1. Yast Software Management

Search for the following packages in the list. Select the checkboxes in front of the
names, and pick the latest version of each package.

The packages:

• make, gcc, gcc-c++, bison, flex, perl, tcl-devel, tk-devel, libxml2-devel, zlib-devel,
java-1_7_0-openjdk, doxygen, graphviz, libwebkitgtk-1_0-0, openmpi-devel, libpcap-
devel

Click Accept, then follow the instructions.
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Chapter 9. Generic Unix

9.1. Introduction

This chapter provides additional information for installing OMNeT++ on Unix-like
operating systems not specifically covered by this Installation Guide. The list includes
FreeBSD, Solaris, and Linux distributions not covered in other chapters.

In addition to Windows and Mac OS X, the Simulation IDE will only work on
Linux x86 32/64-bit platforms. Other operating systems (FreeBSD, Solaris, etc.) and
architectures may still be used as simulation platforms, without the IDE.

9.2. Dependencies

The following packages are required for OMNeT++ to work:

build-essential, GNU make,
gcc, g++, bison (2.x+), flex,
perl

These packages are needed for compiling OMNeT++
and simulation models, and also for certain
OMNeT++ tools to work. Some C++ compilers other
than g++, for example the Intel compiler, will also be
accepted.

The following packages are strongly recommended, because their absence results in
severe feature loss:

Tcl/Tk 8.5 or later Required by the Tkenv simulation runtime
environment. You need the devel packages that
include the C header files as well. It is also possible
to compile OMNeT++ without Tcl/Tk (and Tkenv), by
turning on the NO_TCL environment variable.

LibXML2 or Expat Either one of these XML parsers are needed for
OMNeT++ to be able to read XML files. The devel
packages (that include the header files) are needed.
LibXML2 is the preferred one.

SUN JRE or OpenJDK,
version 7.0 or later

The Java runtime is required to run the Eclipse-
based Simulation IDE. Other implementations, for
example Kaffe, have been found to have problems
running the IDE. You do not need this package if you
do not plan to use the Simulation IDE.

xulrunner This package is part of Firefox, and is needed by
the IDE to display documentation, styled tooltips and
other items.

The following packages are required if you want to take advantage of some advanced
OMNeT++ features:

GraphViz, Doxygen These packages are used by the NED documentation
generation feature of the IDE. When they are missing,
documentation will have less content.
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MPI openmpi or some other MPI implementation is required to
support parallel simulation execution.

Akaroa Implements Multiple Replications In Parallel (MRIP).
Akaroa can be downloaded from the project’s website.

Pcap Allows simulation models to capture and transmit network
packets bypassing the operating system’s protocol stack. It
is not used directly by OMNeT++, but OMNeT++ detects
the necessary compiler and linker options for models in
case they need it.

The exact names of these packages may differ across distributions.

9.3. Determining Package Names

If you have a distro unrelated to the ones covered in this Installation Guide, you need
to figure out what is the established way of installing packages on your system, and
what are the names of the packages you need.

9.3.1. Tcl/Tk

Tcl/Tk may be present as separate packages (tcl and tk), or in one package (tcltk).
The version number (e.g. 8.5) is usually part of the name in some form (85, 8.5, etc).
You will need the development packages, which are usually denoted with the -dev or
-devel name suffix.

Troubleshooting:

If your platform does not have suitable Tcl/Tk packages, you may still use OMNeT++ to
run simulations from the command line. To disable the graphical runtime environment
use:

$ NO_TCL=yes ./configure

This will prevent the build system to link with Tcl/Tk libraries. This is required also if
you are installing OMNeT++ from a remote terminal session.

By default, the configure script expects to find the Tcl/Tk libraries in the standard
linker path (without any -Ldirectory linker option) and under the standard names
(i.e. with the -ltcl8.4 or -ltcl84 linker option). If you have them in different places
or under different names, you have to edit configure.user and explicitly set TK_LIBS
there (see the Build Options chapter for further details).

If you get the error no display and DISPLAY environment variable not set, then you’re
either not running X (the wish command, and thus ./configure won’t work just in
the console) or you really need to set the DISPLAY variable (export DISPLAY=:0.0
usually does it).

If you get the error: Tcl_Init failed: Can’t find a usable init.tcl…

The TCL_LIBRARY environment variable should point to the directory which contains
init.tcl. That is, you probably want to put a line like

export TCL_LIBRARY=/usr/lib/tcl8.4

into your ~/.bashrc.

If you still have problems installing Tcl/Tk, we recommend visiting the OMNeT++
site’s wiki packages for further troubleshooting tips: http://www.omnetpp.org/pmwiki/
index.php?n=Main.TclTkRelatedProblems

http://www.omnetpp.org/pmwiki/index.php?n=Main.TclTkRelatedProblems
http://www.omnetpp.org/pmwiki/index.php?n=Main.TclTkRelatedProblems
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9.3.2. The Java Runtime

You need to install the Oracle JRE or OpenJDK. The IDE is not supported on Unix
platforms other than Linux, so JRE is not required either. We have tested various other
Java runtimes (gcj, kaffe, etc.), and the IDE does not work well with them.

Java version 6.0 (i.e. JRE 1.6) or later is required and 7.0 is recommended.

9.3.3. MPI

OMNeT++ is not sensitive to the particular MPI implementation. You may use
OpenMPI, or any other standards-compliant MPI package.

9.4. Downloading and Unpacking

Download OMNeT++ from http://omnetpp.org. Make sure you select to download the
generic archive, omnetpp-4.6-src.tgz.

Copy the archive to the directory where you want to install it. This is usually your home
directory, /home/<you>. Open a terminal, and extract the archive using the following
command:

$ tar xvfz omnetpp-4.6-src.tgz

This will create an omnetpp-4.6 subdirectory with the OMNeT++ files in it.

9.5. Environment Variables

In general OMNeT++ requires that its bin directory should be in the PATH. You should
add a line something like this to your .bashrc:

$ export PATH=$PATH:$HOME/omnetpp-4.6/bin

You may also have to specify the path where shared libraries are loaded from. Use:

$ export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$HOME/omnetpp-4.6/lib

If configure complains about not finding the Tcl library directory, you may specify it
by setting the TCL_LIBRARY environment variable.

If you use a shell other than bash, consult the man page of that shell to find out which
startup file to edit, and how to set and export variables.

9.6. Configuring and Building OMNeT++

In the top-level OMNeT++ directory, type:

$ ./configure

The configure script detects installed software and configuration of your system.
It writes the results into the Makefile.inc file, which will be read by the makefiles
during the build process.

http://omnetpp.org
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Figure 9.1. Configuring OMNeT++

Normally, the configure script needs to be running under the graphical environment
(X11) in order to test for wish, the Tcl/Tk shell. If you are logged in via an ssh session,
or there is some other reason why X is not running, the easiest way to work around
the problem is to tell OMNeT++ to build without Tcl/Tk. To do that, use the command

$ NO_TCL=1 ./configure

instead of plain ./configure.

If there is an error during configure, the output may give hints about what went
wrong. Scroll up to see the messages. (Use Shift+PgUp; you may need to increase the
scrollback buffer size of the terminal and re-run ./configure.) The script also writes
a very detailed log of its operation into config.log to help track down errors. Since
config.log is very long, it is recommended that you open it in an editor and search
for phrases like error or the name of the package associated with the problem.

The configure script tries to build and run small test programs that are using specific
libraries or features of the system. You can check the config.log file to see which
test program has failed and why. In most cases the problem is that the script cannot
figure out the location of a specific library. Specifying the include file or library location
in the configure.user file and then re-running the configure script usually solves
the problem.

When ./configure has finished, you can compile OMNeT++. Type in the terminal:

$ make
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Figure 9.2. Building OMNeT++

To take advantage of multiple processor cores, add the -j2 option to the make
command line.

The build process will not write anything outside its directory, so no special privileges
are needed.

The make command will seemingly compile everything twice. This is because both
debug and optimized versions of the libraries are built. If you only want to build one
set of the libraries, specify MODE=debug or MODE=release:

$ make MODE=release

9.7. Verifying the Installation

You can now verify that the sample simulations run correctly. For example, the dyna
simulation is started by entering the following commands:

$ cd samples/dyna
$ ./dyna

By default, the samples will run using the Tcl/Tk environment. You should see nice gui
windows and dialogs.

9.8. Starting the IDE

The IDE is supported only on Windows, Mac OS X (x86) and Linux (x86,x64).

You can run the IDE by typing the following command in the terminal:

$ omnetpp
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Figure 9.3. The Simulation IDE

If you would like to be able to access the IDE from the application launcher or via a
desktop shortcut, run one or both of the commands below:

$ make install-menu-item
$ make install-desktop-icon

The above commands assume that your system has the xdg commands, which most
modern distributions do.

9.9. Optional Packages

9.9.1. Akaroa

If you wish to use Akaroa, it must be downloaded, compiled, and installed manually
before installing OMNeT++.

As of version 2.7.9, Akaroa only supports Linux and Solaris.

Download Akaroa 2.7.9 from: http://www.cosc.canterbury.ac.nz/research/RG/net_sim/
simulation_group/akaroa/download.chtml

Extract it into a temporary directory:

$ tar xfz akaroa-2.7.9.tar.gz

Configure, build and install the Akaroa library. By default, it will be installed into the
/usr/local/akaroa directory.

$ ./configure
$ make
$ sudo make install

Go to the OMNeT++ directory, and (re-)run the configure script. Akaroa will be
automatically detected if you installed it to the default location.

9.9.2. PCAP

The optional Pcap library allows simulation models to capture and transmit network
packets bypassing the operating system’s protocol stack. It is not used directly by

http://www.cosc.canterbury.ac.nz/research/RG/net_sim/simulation_group/akaroa/download.chtml
http://www.cosc.canterbury.ac.nz/research/RG/net_sim/simulation_group/akaroa/download.chtml
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OMNeT++, but OMNeT++ detects the necessary compiler and linker options for
models in case they need it.
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Chapter 10. Build Options

10.1. Configure.user Options

The configure.user file contains several options that can be used to fine-tune the
simulation libraries.

You always need to re-run the configure script in the installation root after changing
the configure.user file.

$ ./configure

After this step, you have to remove all previous libraries and recompile OMNeT++:

$ make cleanall
$ make

Options:

USE_NAMESPACE=no Turning on this option will place all OMNeT++
APIs into the omnetpp namespace to prevent name
collisions with other libraries. After that, models
must be updated to either import the namespace or
use qualified names. To compile unmodified models,
use -DAUTOIMPORT_NAMESPACE in the compiler
flags (CFLAGS).

PREFER_CLANG=no If both gcc and clang are installed on your system,
setting this variable to yes will force the configure
script to use clang as C++ compiler.

USE_CXX11=yes By default OMNeT++ is configured to use C+11
language features. This can be disabled if
your model is not yet compatible with C+11.
Future OMNeT++ versions may require C++11, so
it is strongly recommended to update your models as
soon as possible.

<COMPONENTNAME>_CFLAGS,
<COMPONENTNAME>_LIBS

The configure.user file contains variables for
defining the compile and link options needed by
various external libraries. By default, the configure
command detects these automatically, but you
may override the auto detection by specifying
the values by hand. (e.g. <COMP>_CFLAGS=-I/
path/to/comp/includedir and <COMP>_LIBS=-
L/path/to/comp/libdir -lnameoflib.)

WITH_PARSIM=no Use this variable to explicitly disable parallel
simulation support in OMNeT++.

WITH_NETBUILDER=no This option allows you to leave out the NED language
parser and the network builder. (This is needed only
if you are building your network with C++ API calls
and you do not use the built-in NED language parser
at all.)
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NO_TCL=yes This will prevent the build system to link with Tcl/
Tk libraries. Use this option if your platform does not
have a suitable Tcl/Tk package and you will run the
simulation only in command line mode. (i.e. You want
to run OMNeT++ in a remote terminal session.)

EMBED_TCL_CODE=no Tcl/Tk is a script language and the source of the
graphical runtime environment is stored as .tcl files
in the src/tkenv directory. By default, these files are
not used directly, but are embedded as string literals
in the executable file. Setting EMBED_TCL_CODE=yes
allows you to move the OMNeT++ installation
without caring about the location of the .tcl
files. If you want to make changes to the Tcl
code, you better switch off the embedding with
the EMBED_TCL_CODE=no option. This way you can
make changes to the .tcl files and see the changes
immediately without recompiling the OMNeT++
libraries.

CFLAGS_[RELEASE/DEBUG] To change the compiler command line options
the build process is using, you should specify
them in the CFLAGS_RELEASE and CFLAGS_DEBUG
variables. By default, the flags required for
debugging or optimization are detected automatically
by the configure script. If you set them
manually, you should specify all options you
need. It is recommended to check what
options are detected automatically (check the
Makefile.inc after running configure and
look for the CFLAGS_[RELEASE/DEBUG] variables.)
and add/modify those options manually in the
configure.user file.

LDFLAGS Linker command line options can be explicitly set
using this variable. It is recommended to check
what options are detected automatically (check the
Makefile.inc after running configure and look for
the LDFLAGS variable.) and add/modify those options
manually in the configure.user file.

SHARED_LIBS This variable controls whether the OMNeT++ build
process will create static or dynamic libraries.
By default, the OMNeT++ runtime is built as
a set of shared libraries. If you want to build
a single executable from your simulation, specify
SHARED_LIBS=no in configure.user to create
static OMNeT++ libraries and then reconfigure
(./configure) and recompile OMNeT++ (make
cleanall; make). Once the OMNeT++ static
libraries are correctly built, your own project have to
be rebuilt, too. You will get a single, statically linked
executable, which requires only the NED and INI files
to run.

It is important to completely delete the OMNeT++ libraries (make cleanall) and
then rebuild them, otherwise it cannot be guaranteed that the created simulations are
linked against the correct libraries.
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The following symbols can be defined for the compiler if you need backward
compatibility with some older OMNeT++ 3.x features. They should be specified on the
compiler command line using the -DSYMBOLNAME syntax. You can add these options
to the CFLAGS_RELEASE or CFLAGS_DEBUG variables (e.g. CFLAGS_RELEASE='-O2 -
DNDEBUG=1 -DSYMBOLNAME').

USE_DOUBLE_SIMTIME OMNeT++ 3.x used double as the type for simulation
time. In OMNeT++ 4.0 and later, the simulation time is
a fixed-point number based on a 64-bit integer.. If you
want to work with double simulation time for some reason
(e.g. during porting an OMNeT++ 3.x model), define the
USE_DOUBLE_SIMTIME symbol for the compiler.

WITHOUT_CPACKET In OMNeT++ 3.x, methods and data related to the
modeling of network packets were included in the
cMessage class. For these parameters, OMNeT++ 4.x
has a new class called cPacket (derived from cMessage).
If you want get back the old behavior (i.e. having a
single cMessage class only), define the WITHOUT_CPACKET
symbol.

10.2. Moving the Installation

When you build OMNeT++ on your machine, several directory names are compiled
into the binaries. This makes it easier to set up OMNeT++ in the first place, but if you
rename the installation directory or move it to another location in the file system, the
built-in paths become invalid and the correct paths have to be supplied via environment
variables.

The following environment variables are affected (in addition to PATH, which also needs
to be adjusted):

OMNETPP_IMAGE_PATH This variable contains the list of directories where Tkenv
looks for icons. Set it to point to the images/ subdirectory
of your OMNeT++ installation.

OMNETPP_TKENV_DIR This variable points to the directory that contains the Tcl
script parts of Tkenv, which is by default the src/tkenv/
subdirectory of your OMNeT++ installation. Normally
you don’t need to set this variable, because the Tkenv
shared library contains all Tcl code compiled in as
string literals. However, if you compile OMNeT++ with
the EMBED_TCL_CODE=no setting and then you move the
installation, then you need to set OMNETPP_TKENV_DIR,
otherwise Tkenv won’t start.

LD_LIBRARY_PATH This variable contains the list of additional directories
where shared libraries are looked for. Initially,
LD_LIBRARY_PATH is not needed because shared libraries
are located via the rpath mechanism. When you move the
installation, you need to add the lib/ subdirectory of your
OMNeT++ installation to LD_LIBRARY_PATH.

On Mac OS X, DYLD_LIBRARY_PATH is used instead of LD_LIBRARY_PATH. On
Windows, the PATH variable must contain the directory where shared libraries (DLLs)
are present.
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10.3. Using Different Compilers

By default, the configure script detects the following compilers automatically in the
path:

• Intel compiler (icc, icpc)

• GNU C/C++ (gcc, g++)

• Clang (clang, clang++)

• Sun Studio (cc, cxx)

• IBM compiler (xlc, xlC)

If you want to use compilers other than the above ones, you should specify the compiler
name in the CC and CXX variables, and re-run the configuration script.

Different compilers may have different command line options. If you use a compiler
other than the default gcc, you may have to revise the CFLAGS_[RELEASE/DEBUG]
and LDFLAGS variables.


